ET创芯网论坛(EETOP)

找回密码

  登录   注册  

搜帖子
汽车电子资料大全(下载奖励300信元)
楼主: topggmq

FPGA与88E1111千兆以太网实现—硬件

[复制链接]
发表于 2015-9-9 18:14:31 | 显示全部楼层
本帖最后由 leonardo_z 于 2015-9-9 18:16 编辑

想请教,88E1111内部PCS自环通,外部RJ45自环不通的问题。

100M模式调试,用的88E1111, GMII/MII to copper,config[0:6]和您的有不同(但通过配置phy的寄存器都改成一样的,除了PHY地址)
现象是:
1 按88e1111的 2.14 Loopback Modes, 自环PCS层,能用signaltap抓到接收数据,格式如您子 “软件1” 中的描述;
2 但是不自环PCS,在88e1111外部,MDI1 +/- 和 MDI2+/- 环起来,就没有接收到数据;
3 过了变压器(HX5008)在RJ45口自环,也收不到数据
auto Neg 使能与否现象都是一样的。PCS层自环通,能否说明88e1111的寄存器设置已经正确了?
回复 支持 反对

使用道具 举报

 楼主| 发表于 2015-9-18 15:50:02 | 显示全部楼层
回复 51# leonardo_z


    不好意思,不知道问题解决没有,你这种现象是数据没有穿过PHY;寄存器按照硬件配置完,读取一下寄存器数据,对应手册去看;需要做个交叉线,PCS都通了,这要是不通大多数是硬件接触问题,芯片供电等都会导致的,好好测测,你这问题不大了
回复 支持 反对

使用道具 举报

发表于 2015-10-15 21:01:22 | 显示全部楼层
请问:我在设置了88E1111的MAC interface Loopback测试时,按照datasheet的2.14.1.1的设置,在一个板子上回环成功了,但是另外一个板子回环不成功。代码都是一样的,内回环不成功的板子,时可用通过External 1000 Mbps Loopback 的测试的,问题怪啊?找不到头绪
回复 支持 反对

使用道具 举报

发表于 2015-10-15 21:09:44 | 显示全部楼层
我想问以下大家是怎么通过MDIO配置88E1111芯片的呢?我的配置是22->0->0->0;我配置的是百兆网,但是读出来的数据却不对(chipscope)看
我想问下大家的配置顺序是?
回复 支持 反对

使用道具 举报

发表于 2015-10-15 21:10:56 | 显示全部楼层
回复 53# zzg207


   请问你的寄存器配置顺序是?读出来寄存器的值啦没有?
回复 支持 反对

使用道具 举报

 楼主| 发表于 2015-10-21 09:18:32 | 显示全部楼层
回复 53# zzg207


    不知道问题解决没有,你这几乎是硬件的问题,首先在此确认原理图正确,之后把有关PHY芯片从新焊接一次,初步猜测是有虚焊的地方,自己调试板子这种现象很正常的
回复 支持 反对

使用道具 举报

 楼主| 发表于 2015-10-21 09:21:52 | 显示全部楼层
回复 54# huojiwei


    配置根iic差不多的,但是我没有后配置参数,通过硬件配置的,读出来的数据不对,说明你根本没有按照正确的时序完成配置,读出来的数自然就对不上的
回复 支持 反对

使用道具 举报

发表于 2015-10-21 14:13:00 | 显示全部楼层
HI,怎么找不到感觉了
回复 支持 反对

使用道具 举报

发表于 2015-10-24 14:02:30 | 显示全部楼层
回复 12# topggmq


大哥,看到你之前调试过千兆,我也准备调试千兆,不知道你的udp是直接例化的官方ip核还是自己写的呢?如果有的话应该不是免费的吧
回复 支持 反对

使用道具 举报

 楼主| 发表于 2015-10-26 16:00:28 | 显示全部楼层
回复 58# amu226


    要啥感觉,没思路了?
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

关闭

站长推荐上一条 /3 下一条

关闭

小黑屋|关于我们|联系我们|ET创芯网 ( 京ICP备:10050787号 京公网安备:11010502037710 )

GMT+8, 2019-11-12 22:26 , Processed in 0.062101 second(s), 8 queries , Gzip On, Redis On.

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表