ET创芯网论坛(EETOP)

找回密码

  登录   注册  

搜帖子
汽车电子资料大全(下载奖励300信元)
楼主: topggmq

FPGA与88E1111千兆以太网实现—硬件

[复制链接]
发表于 2015-3-11 23:15:56 | 显示全部楼层
link100亮,duplex亮,tx发送时led亮,但是电脑就是接收不到数据?有人遇到过这个问题嘛?
回复 支持 反对

使用道具 举报

 楼主| 发表于 2015-3-12 08:19:18 | 显示全部楼层
回复 21# atom1108


    你要是确认你说的硬件状态对,之后就是你发送数据了,不是发送的任何数据都能接收到,没有正确的数据,网卡会给滤掉
回复 支持 反对

使用道具 举报

发表于 2015-3-12 09:01:05 | 显示全部楼层
不错。学习了
回复 支持 反对

使用道具 举报

发表于 2015-3-16 19:04:45 | 显示全部楼层
楼主写的相当好啊。不知道你的以太网接口是工作在百兆模式还是千兆模式?
88E1111芯片发热厉害吗?
回复 支持 反对

使用道具 举报

 楼主| 发表于 2015-3-17 08:40:11 | 显示全部楼层
回复 24# wgphgp500


    千兆的以太网,有数据传输就发热,但是问题不大,原来怕出问题还加过散热,事实说明不加没啥问题的。
回复 支持 反对

使用道具 举报

发表于 2015-3-20 00:39:24 | 显示全部楼层
好经验分享,太实用了
回复 支持 反对

使用道具 举报

发表于 2015-3-20 09:59:25 | 显示全部楼层
请教个问题 我也是用的这款phy芯片 生成了一个rgmii v2.0的emac core 1G 和100/10M 通信都正常 但是设成tri模式就不能自适应 谢谢
回复 支持 反对

使用道具 举报

 楼主| 发表于 2015-3-27 16:20:55 | 显示全部楼层
回复 27# elotb123


    最近忙着项目了,一直没有关注,你的问题:我没有用过你这种方式,还有你只说不能用,说说具体情况方可知道能否帮助你。
回复 支持 反对

使用道具 举报

发表于 2015-4-28 09:33:33 | 显示全部楼层
最近我也在调试FPGA与88E1111,我不是做硬件的,我是写FPGA代码。现在各种都调通了,就有一些问题不知大家都遇到没有,
FPGA与PC机(用网口调试助手)通信时
1、采用UDP协议,FPGA接收数据时,PC机需要发送2~3(有时候4~5次,这概率有点小)次,FPGA才能收到,如果不通过外网(PC机与FPGA板子直接相连)PC机需要发送1~2,这是为什么?
2、PC机接收数据是,会有数据包丢失,大概1000多包丢失1包,随机丢失,这是为什么?
最近调的很烦,如果有正在调试的,欢迎一起交流,谢谢
回复 支持 反对

使用道具 举报

发表于 2015-4-28 15:44:51 | 显示全部楼层
看一看,学一学!
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

关闭

站长推荐上一条 /3 下一条

关闭

小黑屋|关于我们|联系我们|ET创芯网 ( 京ICP备:10050787号 京公网安备:11010502037710 )

GMT+8, 2019-11-13 20:59 , Processed in 0.081948 second(s), 9 queries , Gzip On, Redis On.

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表