在线咨询 切换到宽版
eetop公众号 创芯大讲堂 创芯人才网

EETOP 创芯网论坛 (原名:电子顶级开发网)

便捷登录,只需一步

找回密码

  登录   注册  

快捷导航
搜帖子
查看: 120|回复: 4

安装calibre2019启动时提示如下错误,怎么解决?

[复制链接]
发表于 3 天前 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?注册

x
/tools/cds/mentor/calibre2019/aoj_cal_2019.3_15.11/bin/calibre_vco: line 80: test: : integer expression expected
/tools/cds/mentor/calibre2019/aoj_cal_2019.3_15.11/bin/calibre_vco: line 85: test: : integer expression expected
/tools/cds/mentor/calibre2019/aoj_cal_2019.3_15.11/bin/calibre_vco: line 89: test: : integer expression expected
/tools/cds/mentor/calibre2019/aoj_cal_2019.3_15.11/bin/calibre_vco: line 101: test: : integer expression expected
Invalid Linux operating system


发表于 前天 07:57 | 显示全部楼层
本帖最后由 nidiya 于 2022-6-23 07:58 编辑

这个应该是由于你的linux系统calibre不支持, 可以偿试修改calibre_vco文件。。在calibre_vco文件中搜索并修改内容:

else
  error_exit 'Invalid Linux operating system'-->这一行修改为VCO=aoj 或者VCO=aoi根据你安装的版本确定
fi`


回复 支持 反对

使用道具 举报

发表于 前天 08:50 | 显示全部楼层
系统不支持,可以改成aoi的版本
回复 支持 反对

使用道具 举报

 楼主| 发表于 前天 09:26 | 显示全部楼层


nidiya 发表于 2022-6-23 07:57
这个应该是由于你的linux系统calibre不支持, 可以偿试修改calibre_vco文件。。在calibre_vco文件中搜索并 ...


好的,谢谢,后来又倒腾了下,应该是系统不支持aoj版本的。
回复 支持 反对

使用道具 举报

 楼主| 发表于 前天 09:29 | 显示全部楼层


CKH 发表于 2022-6-23 08:50
系统不支持,可以改成aoi的版本


好的,应该是这个原因了,我的系统是Redhat5.8,只能装ixl版本的,不然就只能升级系统了,非常感谢!!!
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

关闭

站长推荐 上一条 /1 下一条

小黑屋| 关于我们| 联系我们| 在线咨询| 隐私声明| EETOP 创芯网 ( 京ICP备:10050787号 京公网安备:11010502037710 )

GMT+8, 2022-6-25 06:50 , Processed in 0.057568 second(s), 8 queries , Gzip On, Redis On.

eetop公众号 创芯大讲堂 创芯人才网
快速回复 返回顶部 返回列表