在线咨询 切换到宽版
eetop公众号 创芯大讲堂 创芯人才网

EETOP 创芯网论坛 (原名:电子顶级开发网)

便捷登录,只需一步

找回密码

  登录   注册  

快捷导航
搜帖子
芯片精品文章合集(500篇!)    创芯人才网--重磅上线啦!
查看: 1579|回复: 15

[求助] VCS运行UVM时报错

[复制链接]
发表于 2022-1-25 16:32:58 | 显示全部楼层 |阅读模式
10资产
求各位大神告知下原因
图片.png

 楼主| 发表于 2022-1-25 16:33:59 | 显示全部楼层
顶一下,求个大神
回复

使用道具 举报

发表于 2022-1-26 01:08:58 | 显示全部楼层
建议uvm_dpi.cc使用工具目录下的
回复

使用道具 举报

发表于 2022-1-26 10:09:57 | 显示全部楼层
同上,为啥要用自己的uvm_dpi.cc文件?
回复

使用道具 举报

 楼主| 发表于 2022-1-26 11:02:34 | 显示全部楼层


formeenjoy 发表于 2022-1-26 01:08
建议uvm_dpi.cc使用工具目录下的


图片.png

改变目录并没有什么区别



回复

使用道具 举报

发表于 2022-1-26 11:16:18 | 显示全部楼层
看一下是不是在环境里没加这个:
    import uvm_pkg::*;
    `include "uvm_macros.svh"
另外,package之间编译结果不共享,调用时需要import
回复

使用道具 举报

 楼主| 发表于 2022-1-26 13:20:43 | 显示全部楼层


笃定 发表于 2022-1-26 11:16
看一下是不是在环境里没加这个:
    import uvm_pkg::*;
    `include "uvm_macros.svh"


不是的,代码都是里面加过了
回复

使用道具 举报

发表于 2022-1-26 13:33:08 | 显示全部楼层
先把编译过的临时文件全部删除试试。在搞个自带的example跑跑看呢,如果还不行,那就要怀疑系统的问题?gcc的版本的问题等等

点评

怎么在vcs脚本里面设置gcc版本  发表于 2022-1-26 14:00
回复

使用道具 举报

发表于 2022-1-26 15:10:49 | 显示全部楼层
没有在vcs中设置过gcc,一般都是用的redhat6.9或centos 6.9以后的版本中自带的gcc,最高的版本用到了7.9
回复

使用道具 举报

 楼主| 发表于 2022-1-26 15:21:09 | 显示全部楼层


dtyuzhou 发表于 2022-1-26 15:10
没有在vcs中设置过gcc,一般都是用的redhat6.9或centos 6.9以后的版本中自带的gcc,最高的版本用到了7.9 ...


就是在跑到stdio.h的莫格function时语法报错了
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

关闭

站长推荐 上一条 /2 下一条

关闭

小黑屋| 关于我们| 联系我们| 在线咨询| 隐私声明| EETOP 创芯网 ( 京ICP备:10050787号 京公网安备:11010502037710 )

GMT+8, 2022-5-28 17:48 , Processed in 0.107345 second(s), 9 queries , Gzip On, Redis On.

eetop公众号 创芯大讲堂 创芯人才网
快速回复 返回顶部 返回列表